ERROR: modinfo: could not find module nf_defrag_ipv6

Discuss usability issues, general maintenance, and general support issues for a grsecurity-enabled system.

ERROR: modinfo: could not find module nf_defrag_ipv6

Postby Wyrmkill » Wed Jun 05, 2013 10:21 am

Attempted to install the latest kernel for CentOS 6.4 in a KVM Virtualized environment. Downloaded latest kernel from, patched with latest grsecurity patch grsecurity-2.9.1-

Went through the menuconfig, everything went fine. Compiling everything was fun. But upon getting to the point of install, it goes through everything, gets down to almost the end, and then I get:

Code: Select all
sh /usr/src/linux- arch/x86/boot/bzImage \
ERROR: modinfo: could not find module nf_defrag_ipv6

I've tried everything I could think of, the google does not provide much insight into the issue. I do see nf_defrag_ipv6 in /sys/module
Steps tried:
1) Disabling ipv6 modules via menuconfig - same result, more errors though
2) Fully enabling all features of ipv6 via menuconfig - same result
3) Re-installing CentOS 6.4 without ipv6 support during install - same result

As a side note, I've recently done this process on both of my other debian servers, and it went flawlessly.

Please let me know what other information I can provide!

Posts: 1
Joined: Wed Jun 05, 2013 10:11 am

Return to grsecurity support