Invalid password when use gradm -D

Submit your RBAC policies or suggest policy improvements

Moderators: spender, PaX Team

Invalid password when use gradm -D

Postby tycjan » Thu Feb 12, 2009 11:34 am

Hello.

I have a problem. When i try disable gradm i see "Invalid password". My password it's 100% correct. I try remove pw file from /etc/grsec and set new password.

Code: Select all
gradm -P
gradm -P admin
then
gradm -a admin
gradm -D


the same result, invalid password. How i can fix it?

P.S
I use kernel 2.6.28.4 on slackware 12.0.
tycjan
 
Posts: 3
Joined: Thu Feb 12, 2009 11:22 am

Re: Invalid password when use gradm -D

Postby tycjan » Thu Feb 12, 2009 7:10 pm

btw, if i reboot the machine gradm will be still enable?
tycjan
 
Posts: 3
Joined: Thu Feb 12, 2009 11:22 am

Re: Invalid password when use gradm -D

Postby spender » Thu Feb 12, 2009 10:17 pm

Any changes to /etc/grsec/pw while the RBAC system is enabled have no effect, for obvious security reasons.

If you reboot the machine, the RBAC system won't be enabled unless you explicitly added it to your init scripts.

-Brad
spender
 
Posts: 2185
Joined: Wed Feb 20, 2002 8:00 pm
Location: VA, USA

Re: Invalid password when use gradm -D

Postby tycjan » Sat Feb 14, 2009 12:21 am

Thank You for answer. I reboot my machine and everything is ok. Now i delete pw file and run again gradm for new password. Thank You for good work.
tycjan
 
Posts: 3
Joined: Thu Feb 12, 2009 11:22 am


Return to RBAC policy development