Segmentation Fault on PHP ( Laravel/composer.phar)

Discuss usability issues, general maintenance, and general support issues for a grsecurity-enabled system.

Moderators: spender, PaX Team

Segmentation Fault on PHP ( Laravel/composer.phar)

Postby jlambrecht » Mon Mar 16, 2015 1:25 pm

While attempting to set-up Laravel on an alpine machine i get a general protection error

i used "curl -sS http://getcomposer.org/installer | php" to succesfully install composer.phar for an unprivilegd user ( using alpine-linux very default install ) Required php packages were installed from the alpine epo to have composer install correctly

Code: Select all
apk add php-json php-phar php-ctype php-openssl php-curl


When i run php composer.phar init all works fine until the final stage, then it hits the themattharris/tmhoauth/ requirement and throws a segmentation fault, resulting in the below dmesg output


    traps: php[1500] general protection ip:6995a77eed52 sp:78ce42079b28 error:0 in ld-musl-x86_64.so.1[6995a77d2000+86000]
    grsec: segmenation fault occurred at (nil) in /usr/bin/php[php:1500] uid/euid:1000/1000 gid/egid:1000/1000, parent /bin/busybox[ash:1499] uid/euid:1000/1000 gid/egid:1000/1000
    grsec: denied resoruce overstep requesting 4096 for RLIMIT_CORE against limit 0 for /usr/bin/php[php:1500] uid/euid:1000/1000 gid/egid:1000/1000, parent /bin/busybox[ash:1499] uid/euid:1000/1000 gid/egid:1000/1000

I can repeat this by running
Code: Select all
php composer.phar require


I'd be happy to provide any feedback.
jlambrecht
 
Posts: 45
Joined: Wed Oct 29, 2014 11:45 am

Return to grsecurity support

cron