Error building FGLRX package

Discuss usability issues, general maintenance, and general support issues for a grsecurity-enabled system.

Moderators: spender, PaX Team

Error building FGLRX package

Postby GBit » Mon Jun 03, 2013 7:24 pm

Code: Select all
Package build failed!
Package build utility output:
./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati-packager.sh: debclean: not found
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 2:12.104-0ubuntu1
dpkg-buildpackage: source changed by AMD: Advanced Micro Devices. <http://ati.amd.com/support/driver.html>
 dpkg-source --before-build fglrx.yJM9ty
dpkg-buildpackage: host architecture amd64
 debian/rules build
Can't exec "debian/rules": Permission denied at /usr/bin/dpkg-buildpackage line 510.
dpkg-buildpackage: error: debian/rules build failed with unknown exit code -1
./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati-packager.sh: debclean: not found
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 2:12.104-0ubuntu1
dpkg-buildpackage: source changed by AMD: Advanced Micro Devices. <http://ati.amd.com/support/driver.html>
 dpkg-source --before-build fglrx.2SmdEu
dpkg-buildpackage: host architecture amd64
 debian/rules build
Can't exec "debian/rules": Permission denied at /usr/bin/dpkg-buildpackage line 510.
dpkg-buildpackage: error: debian/rules build failed with unknown exit code -1
./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati-packager.sh: debclean: not found
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 2:13.101-0ubuntu1
dpkg-buildpackage: source changed by AMD: Advanced Micro Devices. <http://ati.amd.com/support/driver.html>
 dpkg-source --before-build fglrx.kQ4rEw
dpkg-buildpackage: host architecture amd64
 debian/rules build
Can't exec "debian/rules": Permission denied at /usr/bin/dpkg-buildpackage line 510.
dpkg-buildpackage: error: debian/rules build failed with unknown exit code -1
[Error] Generate Package - error generating package : Ubuntu/raring


This is the 13.6 beta driver (same error on 13.4 stable) on Ubuntu raring.

Kernel config:
http://pastebin.com/TQN80rsf
GBit
 
Posts: 81
Joined: Mon Jun 04, 2012 3:31 pm

Return to grsecurity support