Boot Error with 3.10

Discuss and suggest new grsecurity features

Moderators: spender, PaX Team

Boot Error with 3.10

Postby fearnop » Thu Jul 11, 2013 6:15 am

Hey guys,

first of all, many thanks for this great work and keepin it alive!

Sadly, im not able to boot the latest kernel 3.10 with the grsec patch-set.
Ive taken an screenshot because i do not have a full stacktrace. maybe it helps you a lil bit.

My kernel-config is working together with grsec since many kernel releases. At least ive used 3.9.8 and migrated via "make oldconfig" to the new 3.10 one.


The screenshot: http://s14.directupload.net/file/d/3313 ... oh_jpg.htm
The kernel-config: http://www.rootfabrik.com/_6tg58u6/3.10.config.txt


Kind regards, Jens :)
fearnop
 
Posts: 9
Joined: Thu Jul 11, 2013 5:45 am

Re: Boot Error with 3.10

Postby PaX Team » Fri Jul 12, 2013 6:42 pm

can you as an experiment switch to SLUB and see if that works?
PaX Team
 
Posts: 2310
Joined: Mon Mar 18, 2002 4:35 pm

Re: Boot Error with 3.10

Postby spender » Fri Jul 12, 2013 8:42 pm

I've fixed the issue with SLAB. It'll be fixed in the next patch.

Thanks,
-Brad
spender
 
Posts: 2185
Joined: Wed Feb 20, 2002 8:00 pm
Location: VA, USA

Re: Boot Error with 3.10

Postby fearnop » Sat Jul 13, 2013 5:43 am

Ive patched the 3.10 kernel with the latest grsec patch (grsecurity-2.9.1-3.10.0-201307122308.patch) and switched to SLUB.

Im able to boot now.

As far as i can see, youve fixed the bug in the above patch, so Ill make a SLAB kernel now and test it.


kind regards, jens
fearnop
 
Posts: 9
Joined: Thu Jul 11, 2013 5:45 am

Re: Boot Error with 3.10

Postby fearnop » Sat Jul 13, 2013 6:30 am

I can confirm the boot-success with 3.10 and grsec-patch "grsecurity-2.9.1-3.10.0-201307122308.patch" with SLAB.
it works again :)

many thanks and the next donation is coming :)
fearnop
 
Posts: 9
Joined: Thu Jul 11, 2013 5:45 am


Return to grsecurity development

cron