3.2.18+grsecurity-2.9-3.2.18-201205301835.patch error (new)

Discuss and suggest new grsecurity features

Moderators: spender, PaX Team

3.2.18+grsecurity-2.9-3.2.18-201205301835.patch error (new)

Postby Troppauer » Thu May 31, 2012 3:23 am

Hi,

The linux-3.2.18+grsecurity-2.9-3.2.18-201205301835.patch compile error:

CHECK include/linux (366 files)
/usr/src/linux-3.2.18/usr/include/linux/media.h:28: included file 'linux/version.h' is not exported
/usr/src/linux-3.2.18/usr/include/linux/soundcard.h:1054: userspace cannot reference function or variable defined in the kernel
make[3]: *** [/usr/src/linux-3.2.18/usr/include/linux/.check] Error 123
make[2]: *** [linux] Error 2
make[1]: *** [headers_check] Error 2
make: *** [vmlinux] Error 2

Regards,
Hal
Troppauer
 
Posts: 11
Joined: Tue Sep 14, 2010 3:27 am
Location: Hungary

Re: 3.2.18+grsecurity-2.9-3.2.18-201205301835.patch error (n

Postby PaX Team » Thu May 31, 2012 6:10 am

Troppauer wrote:/usr/src/linux-3.2.18/usr/include/linux/media.h:28: included file 'linux/version.h' is not exported
/usr/src/linux-3.2.18/usr/include/linux/soundcard.h:1054: userspace cannot reference function or variable defined in the kernel
looks like commit cb97914b04e7b587cf555ec5b1c69d61014f3378 was never backported to 3.2, fixed in the next patch.
PaX Team
 
Posts: 2310
Joined: Mon Mar 18, 2002 4:35 pm

Re: 3.2.18+grsecurity-2.9-3.2.18-201205301835.patch error (n

Postby jacekalex » Thu May 31, 2012 9:36 pm

Hi

I have a similar error in the hardened-sources-3.3.7
Code: Select all
*hardened-sources-3.3.7 (28 May 2012)
....
  Based on 3.3.7 + genpatches-3.3-8 + grsecurity-2.9-3.3.7-201205271953 + layer7

and this patch:
Code: Select all
4200_fbcondecor-0.9.6.patch
600-netfilter_layer7_2.22.patch
601-netfilter_layer7_pktmatch.patch
602-netfilter_layer7_match.patch
603-netfilter_layer7_2.6.36_fix.patch
620-sched_esfq.patch
imq-3.3.diff

source patches:
http://dev.gentoo.org/~mpagano/genpatches/trunk/3.3/
https://dev.openwrt.org/browser/trunk/t ... atches-3.3
http://www.linuximq.net/patches.html

error log:
Code: Select all
  CHK     include/generated/linux/version.h
make[1]: Nothing to be done for `all'.
  CHK     include/generated/utsrelease.h
  CALL    scripts/checksyscalls.sh
  CHK     include/generated/compile.h
  CHK     kernel/config_data.h
  CHK     include/generated/linux/version.h
make[2]: Nothing to be done for `all'.
make[3]: *** No rule to make target `/usr/src/linux-3.3.7-hardened/include/linux/version.h', needed by `/usr/src/linux-3.3.7-hardened/usr/include/linux/.install'.  Stop.
make[3]: *** Waiting for unfinished jobs....
make[2]: *** [linux] Error 2
make[1]: *** [headers_install] Error 2
make: *** [vmlinux] Error 2


On hardened-sources-3.3.6
Code: Select all
Based on 3.3.6 + genpatches-3.3-6 + grsecurity-2.9-3.3.6-201205131658

the same set of patches compiles correctly. :)

Regards
8)
jacekalex
 
Posts: 39
Joined: Tue Jan 11, 2011 2:16 pm
Location: Poland

Re: 3.2.18+grsecurity-2.9-3.2.18-201205301835.patch error (n

Postby PaX Team » Fri Jun 01, 2012 3:12 am

jacekalex wrote:
Code: Select all
*hardened-sources-3.3.7 (28 May 2012)
....
  Based on 3.3.7 + genpatches-3.3-8 + grsecurity-2.9-3.3.7-201205271953 + layer7
can you try the latest grsec?
PaX Team
 
Posts: 2310
Joined: Mon Mar 18, 2002 4:35 pm

Re: 3.2.18+grsecurity-2.9-3.2.18-201205301835.patch error (n

Postby jacekalex » Fri Jun 01, 2012 1:02 pm

Hi

I'm going to wait for the next version of the hardened-sources.
I am currently using the default profile grsec-virtualization, and the kernel 3.3.6 works fine, also no problem.
I wrote a previous post, just to signal the presence of this error in the patches for 3.3.7.

Edit:
Code: Select all
  +hardened-sources-3.3.7-r1.ebuild:
  Based on 3.3.7 + genpatches-3.3-8 + grsecurity-2.9-3.3.7-201206011935

works fine.

Thanks :)

Regards
8)
jacekalex
 
Posts: 39
Joined: Tue Jan 11, 2011 2:16 pm
Location: Poland


Return to grsecurity development